Controle remoto do Chery QQ 2011/2012 (S11) pisca LED mas não aciona travas e central de alarme

Depois de algumas investidas DIY no sapinho, estive lutando nesse controle quando ele passou a dar umas rateadas na hora de acionar a central. É um circuito bem simples, sem muita frescura - como o próprio carro - e eu não conseguia entender o porquê de ele oscilar mas não enviar sinal corretamente pra central.

Quando comprei esse carro, achei estranho terem colocado duas baterias no controle remoto, CR20XX não me lembro, mas é das mais fininhas. Pensei que fosse preguiça da ex-dona de resolver o problema da folga e do mal contato da bateria, eliminando um espaço entre a placa e os contatos com outra bateria. Sem falar que estava mascarando um defeito ao alimentar com 6V um RF projetado para operar com 3V. Mas não era preguiça. Já tinha esse problema crônico. Hoje, finalmente consegui deixar o carinha afiado e funcionando até de longe.

Não vou me aprofundar nem entrar no beabá do RF, mas quem entende um pouco de eletrônica sabe que em áudio e RF a qualidade da alimentação é fundamental para que o circuito funcione como o esperado. Nesse caso aqui em especial, colocaram um LED vermelho que pisca quando você pressiona uma das teclas. Antes de sair trocando o transistor R25 e medindo todos os capacitores, decidi simplesmente testar esse controle com mais corrente, mantendo a tensão. Fiz o teste utilizando uma célula de lítio com carga de 3,2V (2,2A) e o RF acionou a central normalmente com apenas um toque sutil nas teclas. Ou seja, alguma coisa estava 'roubando' corrente do CI, tornando a oscilação fora de padrão e interferindo na transmissão. Um adendo aqui: não sou especialista em RF, nunca trabalhei com radiofrequência aplicada, nunca fui um entusiasta da área; apenas conheço os conceitos e procuro aplicá-los da forma correta. Quando falta informação, tem a internet. Não pretendo transformar esse assunto num debate de clubinho.

Antes disso, fiz um reforço com fio de cobre pra antena desse controle, que nada mais é do que uma trilha mais grossa que quase faz uma volta completa em uma das faces da PCI. Mas o que efetivamente funcionou foi retirar da placa o resistor de 1k (R6) em série com esse LED vermelho. Toda a corrente e tensão da CR2032 foram dedicados ao CI que instantaneamente passou a funcionar como deveria. Fiz testes de muito longe, dentro do possível que meu pátio permite, e o controle acionou a central de forma eficaz e sem rodeios mesmo com toques curtos e breves. Antes dessa descoberta, pensei serem os botões o problema, mas descartei logo que fiz testes de continuidade neles. Estavam perfeitos. Era um saco quando o controle resolvia não funcionar o destravamento das portas. Muita força a troco de nada, como quando as pilhas do controle remoto da TV ficam fracas e a gente aperta mais forte como se isso fosse resolver alguma coisa. Casa de ferreiro...

Nunca entendi esses LEDs em controles de RF. Acho desnecessário e cruel para quem precisa ficar trocando essas CR2032 de dois em dois meses. Quando tinha moto, instalei o alarme dela e os dois controles (o de presença e o comum) tinham LEDS AZUIS! Uma piada, consumiam muitas pilhas ao ponto de eu só usar o de presença escondido comigo e deixar o comum sem pilha preso ao chaveiro pra entregar a um possível vagabundo que pudesse levar a moto num assalto.

Então, se você tem um QQ ou um outro veículo que possua controle remoto com LED, recomendo fortemente desativar pra economizar pilhas. E em alguns casos, também pra manter o RF redondinho. Cada caso é um caso, mas vale a pena avaliar se é possível desativar o LED sem prejuízo do funcionamento do circuito. E vale mais ainda a dica para quem pretende levar o controle pra conserto nesses chaveiros de esquina, que vão cobrar um monte de dinheiros de você e que talvez nem consigam resolver seu problema. 

Detalhe do resistor R6 retirado

Decidi manter o reforço da antena


Central de alarme de incêndio Engesul Intelbras Slim - como transformar em central de alarme residencial?!

Após alguns meses de estagnação e falta de ideias e de dinheiro também (falando nisso, aqui tem meios bacanas de dar aquela mãozinha pro site) ganhei uma central de alarme de incêndio Engesul Slim. Já tinha visto delas pelo comércio, instaladas e funcionando, e sempre me perguntei como essa bagaça funcionava. Dando aquela estudada no manual dela, pude entender que não se trata de nada além de uma central de alarme residencial com foco nos PPCI obrigatórios. Ou seja, é possível adaptar seu uso para monitoramento residencial de portas, janelas etc.

Logo, aqui se inicia a saga de transformar essa central em uma central de alarme residencial. Para começar, vou deixar o link do manual dela para os nerds de plantão torcendo pro link não sair do ar - já que a Intelbras tirou essa central de linha. Mas se isso acontecer e o projeto der certo, vai ganhar asilo permanente no Drive diyPowered.

11/06/2020, 7h40 - Dia 1

Liguei a central pra ver se dava algum sinal de vida e ela pelo menos está ligando. O display está com alguns pontos queimados mas isso se resolve facilmente, já que tenho alguns LCD compatíveis em mãos. As baterias (2x 12V 2,3A em série) estão esgotadas mas vou tentar ressuscitá-las e ver se ainda aguentam algum tempo.

Uma coisa bacana que já gostei nesse sistema é que ele monitora as tensões tanto da fonte de alimentação (DC) quanto das baterias e mostra a informação no display. Olhando aqui por cima parece ser um daqueles projetos robustos, sem frescuras e que dificilmente dá problema. Parece bastante com o projeto da central de alarme ZSE que tive há alguns anos - com a exceção do rádio que ela tinha para sensores sem fio endereçáveis nos setores. Vou fazendo meus experimentos e criando um log nessa mesma postagem para não criar aqueles tópicos mil sobre o mesmo assunto dentro do site.


14/06/2020, 8h04 - Dia 2

As baterias estão mortas, mas isso já era esperado mesmo. Testei os disparos e descobri como funciona o gatilho dos laços (ou setores) para que a central acione o alarme geral: quando o setor está em aberto (NA) com apenas o resistor de 4,7k em paralelo a central entende que houve uma violação de um sensor e dispara o alarme registrando também na memória (RAM) o evento com data e hora e o endereço. Fechando um curto no setor, a central entende que os sensores estão em espera e a central segue apenas monitorando. Isso nos diz que preciso desenvolver (ou encontrar no mercado) sensores do tipo NF que se torne NA na violação. Fácil.

O display está mesmo meio esquisito, mas talvez seja 'normal' que ele trabalhe meio 'borrado', só vou saber quando trocar ele. No mais, preciso dessas baterias para prosseguir com a saga. Ainda não entendi completamente o funcionamento do sistema, como por exemplo na hora de bloquear ou liberar os laços, ela só habilita dois laços ficando o 3 e o 4 inativos com traços (---) mas isso fica pra depois.

Como já sabemos que o circuito está ok, vou verificar esses laços 3 e 4 fisicamente na placa pra ver se tem algum dano e depois já limpo e monto a central pro aguardo das baterias.

28/06/2020, 14h25 - Dia 3

Falei antes que não sabia o porquê de os laços 3 e 4 estarem com traços (---) na configuração. Descobri que eles ficam assim porque não foram cadastrados os pontos. Fiz um teste e deu certo. As baterias ainda não consegui reposição por falta de dinheiro mesmo, mas como não há pressa... vamos brincando. Mais adiante pretendo montar um sensor experimental para aberturas (portas, janelas, portões etc.) talvez até sem fio. Vamos ver.

Cícero in memoriam (26).

19/08/2020, 10h52 - Dia 4

Esse projeto entrou oficialmente para a regra dos seis meses diyPowered a partir de hoje: reza a lenda interna que se um projeto permanece estagnado por seis meses ele é encerrado. Uma das razões dessa falta de continuidade nesse projeto (além da falta de $$) é que talvez ocorra uma mudança de endereço (talvez de Estado) e os esforços para instalar a central podem ser em vão nesse momento. E também tem o projeto da nova fonte de bancada que emerge com mais urgência porque a antiga está praticamente parada.